VMware: Se produjo un problema durante “Starting VMware Identity Management Service”.

VMware: Se produjo un problema durante “Starting VMware Identity Management Service”.

Recientemente actualizando vCenter de la versión 6.5 a la 6.7 en la fase 2 de la actualización, concretamente en el 5% del proceso, me dio el siguiente error: “Se produjo un problema durante – Starting VMware Identity Management”.

Este error normalmente se debe a una de las siguientes causas.

Registros DNS incorrectos

Es muy importante que el FQDN de nuestro vCenter resuelva correctamente a su correspondiente IP y también en sentido inverso, es decir, la IP sea capaz de resolver al FQDN de nuestro vCenter.

En el caso que esta sea la causa de nuestro error tendremos que realizar lo siguiente antes de iniciar la fase 2 de nuestro proceso de actualización.

Abrir una consola en nuestro nuevo VCSA y habilitar SSH en el caso que no estuviera habilitado.

Posteriormente conectarnos vía SSH y ejecutar el siguiente comando.

echo "::1 localhost.localdom localhost" >> /etc/hosts

Una vez ejecutado ya deberíamos poder continuar con el proceso de actualización sin problemas.

En el caso que aún haciendo esto que te comento sigas teniendo problemas te aconsejo que pruebes con el siguiente punto.

Puerto 11711 Active Directory

Si venimos actualizando nuestro vCenter desde la versión 5.5 o 6.0 seguramente nuestro problema venga derivado del puerto configurado de active directory en nuestro vCenter.

Por defecto el puerto utilizado es el 11711. Esta configuración es válida para las versiones 5.5, 6.0 y 6.5 no así para la versión 6.7 en la cual ha dejado de usarse.

Para solucionar el problema tendremos que actuar de la siguiente manera en función si nuestro vCenter se encuentra en una máquina Linux o Windows.

Linux

Nos conectaremos por SSH a nuestro VCSA actual (versión 6.5 o anterior) y obtendremos un listado de puertos para verificar si realmente tenemos el puerto 11711 configurado en nuestro VCSA. Para ello ejecutaremos el siguiente comando.

 /opt/likewise/bin/lwregshell list_values "[HKEY_THIS_MACHINE\\Services\\vmdir\\Parameters]" 

En el caso que la consulta nos devuelva lo siguiente continuaremos, en caso contrario este no sería nuestro problema y no continuaremos.

 "LdapPort"                    REG_DWORD       0x00002dbf (11711). 

Cambiamos el puerto 11711 por el puerto 0 con el siguiente comando.

 /opt/likewise/bin/lwregshell set_value "[HKEY_THIS_MACHINE\\Services\\vmdir\\Parameters]" LdapPort 0
 

Reiniciamos los servicios.

service-control --stop lwsmd
service-control --start lwsmd
/opt/likewise/bin/lwsm autostart 

Comprobamos que el puerto se ha modificado de forma correcta.

 /opt/likewise/bin/lwregshell list_values "[HKEY_THIS_MACHINE\\Services\\vmdir\\Parameters]"  

Si todo ha ido correcto nos debe salir lo siguiente.

 "LdapPort"                         REG_DWORD       0x00000000 (0) 

Con estos pasos habremos solucionado nuestro problema y podremos continuar con la actualización de nuestro VCSA a la versión 6.7.

Windows

Abrimos el registro de Windows con el comando regedit.exe.

Nos dirigiremos a la siguiente ruta:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VmwareDirectoryService\Parameters\

Modificaremos el parámetro “LdapPort” a 0. En el caso que no exista el parámetro no tendremos que hacer nada al no estar afectados por este bug.

Con estos pasos habremos solucionado nuestro problema y podremos continuar con la actualización de nuestro vCenter a la versión 6.7.

Espero os sirva de utilidad.

Entradas relacionadas

Deja un comentario