VMware: Como solucionar la alarma del estado del RBD en vCenter 6.7

Hoy voy a explicaros como podéis solucionar la alarma del estado del RBD en vCenter 6.7.

Lo primero que hice, cuando me encontré el error, fue investigar ya que desconocía que era RBD y con que característica de VMware estaba relacionado. Pude ver que esta alerta es producida por un mal funcionamiento de la característica Auto Deploy de VMware.

Para aquellos que no lo conozcáis esta característica nos permite implementar software ESXi, entre otras cosas, a una serie de hosts físicos que definamos de forma automatizada. Esto es una gran ventaja si tenemos un parque de hosts muy grande y queremos prepararlos de una forma rápida.

Identificado el problema lo primero que hice fue irme a la consola HTML 5 de mi vCenter y seleccionar Menú-Autodeploy para ver si podía obtener alguna pista más sobre el problema.

Aquí tenía un nuevo mensaje de error el cual hacía referencia al servicio Image Builder y me indicaba que este servicio se encontraba inactivo.

El siguiente paso que di fue conectarme a VAMI (https://vcenter:5480), irme a la parte de Servicios y comprobar el estado del servicio Image Builder.

Vi que este servicio, por defecto, tiene un tipo de inicio manual y se encontraba detenido. También pude apreciar que el servicio Auto Deploy se encontraba en estado degradado por lo que en primer lugar inicié el servicio ImageBuilder y posteriormente reinicié el servicio Auto Deploy.

Al reiniciar el servicio Auto Deploy me pidió confirmación por lo que pulsé en Aceptar para continuar.

Una vez iniciado el servicio ImageBuilder y reiniciado el servicio Auto Deploy ambos servicios pasaron al estado correcto.

Parecía que todo estaba ya solventado pero cual fue mi sorpresa al irme nuevamente a vCenter y comprobar que el error seguía en la pantalla principal pero en cambio dentro de AutoDeploy el error ya había desaparecido. Como no me cuadraba lo que hice fue ver la configuración de la alarma para ver si tenía que esperar un tiempo hasta que desapareciera.

Según la definición de la alarma tras haber reiniciado los servicios y haber solucionado el problema automáticamente debería haber desaparecido el mensaje de alerta pero como no fue así lo que hice fue comprobar, de forma manual, el estado del componente RBD para verificar efectivamente que ya se encontraba en el estado correcto.

Para comprobar el estado de RBD abrí mi navegador de Internet y me dirigí a la siguiente url https://<vcenter:6502/vmw/rbd/health-info

Aquí pude comprobar que efectivamente el problema del componente RBD se había solucionado y por tanto deduje que debía haber algún tipo de bug en la versión de vCenter 6.7 por el cual la alarma no detecta el cambio de estado y por tanto no hace desaparecer de forma automática el mensaje de alerta.

Una vez comprobé que todo estaba correcto y que ya efectivamente no había ningún problema restablecí, de forma manual, la alerta a verde y así hasta el día de hoy en el que ya nunca más ha vuelto a aparecer la alarma y todo funciona correctamente.

Espero os haya servido de utilidad.

Entradas relacionadas

Deja un comentario